manage and control versions of Photoshop files within Adobe Photoshop

Download Timeline Lite

Here you can download Timeline plug-in for Adobe Photoshop.


Please note,
to enjoy Timeline Lite you will need a PixelNovel account.

Please sign up to get an account if you haven't done it yet.


It's free.




Requirements: Adobe Photoshop CS2, CS3, CS4
Windows XP and above
doesn’t support PROXY yet (we’re working on it!)

Requirements: Adobe Photoshop CS2, CS3, CS4
Mac 10.4 and above

These versions of Timeline Lite are based on SVN 1.6.4. Do you need another version of SVN? Download an older release of Timeline